PLA Forums

Other Stuff That Has Little To Do With PLA => Techinical Shit => Operating Systems => Topic started by: MattGSX on January 19, 2010, 03:03:34 PM

Title: DS Linux
Post by: MattGSX on January 19, 2010, 03:03:34 PM
So I hadn't used DS Linux for almost a year, but just re-downloaded and reinstalled. I have to say, things have certainly gotten better. New features:

1. The microphone works now, and you can record and playback audio.
2. Beta stages for a semi-graphical browser.
3. Beta for a very simple desktop environment.
4. profile-based wnc
5. I haven't run out of memory yet.

There are some annoying features, though. For example, DHCP almost never works with me. I'm not always in a situation where I can log into the router I'm trying to log into, set up static IPs, and then log in (IE, school). That's fine for me at work, but that's about it.

When processes hang, opening a new virtual terminal and trying to kill the process almost never works. This generally happens for me with Links and when trying to ping a router to verify I'm connected. I run ps to get the correct pid. But I still can't kill the bitch.

I also can't figure out how to kill my network without restarting the DS. Why would I want to do this? Because networking drains my battery, and I only want to use wi-fi when I have to. I don't want to have to restart my computer every time I go offline. I don't have to do that with my laptop. GRRR

[EDIT] Nevermind. There's a command within wnc to turn off networking. However, when I connect to a network through DHCP, I log into my router and see I've been assigned an IP, but I still can't use the internet. I try pinging the network and it just hangs indefinitely. I try opening links and it hangs indefinitely. Weak.
That's about it.
Title: Re: DS Linux
Post by: trevelyn on February 03, 2010, 06:35:03 AM
is there a route command? does your dhcp client add your DNS properly to it's config file? e.g. /etc/resolv.conf ?